 How to fix macOS

This blog post focuses on a number of tips and tweaks that will help to make your macOS experience better, faster, and more efficient.

How to update macOS from Terminal

Open the Terminal and type in the following:

sudo softwareupdate -ia

How to ensure macOS checks for new software updates daily

Within the Terminal type the following:

defaults write com.apple.SoftwareUpdate ScheduleFrequency -int 1

How to copy text from a website and paste it quickly into a text file

Head to the Keyboard section within System Preferences and highlight the Services section. Next, in the secondary panel scroll down you see “New TextEdit…..”. From there add your shortcut keyboard combination.
Next, copy text from a website and use your new shortcut keyboard combination. The copied text will automatically be pasted into TextEdit

 
 How to add emojis in your documents quickly

Within macOS, select your text-based application and then type the following key combination:

Command + Control + Space

This will launch the emoji selector.

How to add a quit option to the Finder

To add a quit option to the Finder, add the following command to the Terminal

defaults write com.apple.finder QuitMenuItem -bool YES

Now type killall Finder into the Terminal window

How to stop macOS from indexing the Applications folder

To turn off Spotlight, open the Terminal and type the following:

sudo mdutil -a -i off

To unload it, type the following into the Terminal

sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist

To load It, type the following into the Terminal

sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist

To turn on Spotlight, type the following into the Terminal

sudo mdutil -a -i on

How to quickly see your IP address and other Wi-Fi networking information

In macOS, hold down Alt (or the Option key on some keyboards) and click the Wi-Fi icon at the top right of the screen. Beneath the name of the currently in-use Wi-Fi base station you will see the networking information and also a disconnect option.

How to force quit an app in macOS

Type the following:

Click Option, Command, and Escape

How to change the location of your screenshot images

Within the Terminal type the following:

defaults write com.apple.screencapture location ~/Dropbox/Screenshots

Where ~/Dropbox/Screenshots is the location where you want the screenshots folder to live.
Now type killall Dock into the Terminal window

How to disable screenshot drop shadows

Within the Terminal type the following:

defaults write com.apple.screencapture disable-shadow -bool TRUE

Now type killall SystemUIServer into the Terminal window

How to shutdown your Mac, with or without a delay

To shut down your Mac immediately:
Type the following into the Terminal:

sudo shutdown -h now

To restart your Mac immediately:

sudo shutdown -r now

We can even add a time delay (in minutes) if we wish:

sudo shutdown -r +60

How to make your Mac talk

Within the Terminal type the following:

say "Hello world"

We can even go one better and have it read any text file we like:

say -f /path/to/file.txt

Your Mac can then say whatever was in the text file.

How to change the default filetype for screenshot images

Within the Terminal type the following:

defaults write com.apple.screencapture type jpg

Now type killall SystemUIServer into the Terminal window

How to add your most recent used applications into the dock

Open Terminal and copy the following command:

defaults write com.apple.dock persistent-others -array-add '{ "tile-data" = { "list-type" = 1; }; "tile-type" = "recents-tile"; }'

Now type killall Dock into the Terminal window

How to show the full file path in Finder

To easily find the hierarchy of folders, you can easily find the full path by adding this tweak to the Terminal.
Open Terminal

defaults write com.apple.finder _FXShowPosixPathInTitle -bool YES

Now type killall Finder into the Terminal window
If you need to change it back, change “YES” to “NO” (without the quotes).

How to add spacers into the dock

If you need a way to organize your dock icons, the following command will allow you to insert a spacer into your dock that you can move around and place anywhere to divide your apps up by category.
Within the Terminal type the following:

defaults write com.apple.dock persistent-apps -array-add '{tile-data={}; tile-type="spacer-tile";}'

Now type killall Dock into the Terminal window
To add more spaces, add the command into the terminal again. If you want to remove the spaces just drag them out of the dock.

How to make hidden apps “hidden” in the dock

If you use ⌘H to hide apps on screen with this tweak, you’ll be able to add transparency to all of your hidden apps so you don’t forget they’re running in the background
Within the Terminal type the following:

defaults write com.apple.Dock showhidden -bool TRUE;

Now type killall Dock into the Terminal window
If you need to change it back, change “YES” to “NO” (without the quotes).

How to eliminate the dock reveal delay

If you need to speed up the dock when you have it hidden, this tweak will speed it up.
For faster animation, within the Terminal type the following:

defaults write com.apple.dock autohide-time-modifier -float 0.12;

Now type killall Dock into the Terminal window
For no animation, within the Terminal type the following:

defaults write com.apple.dock autohide-time-modifier -int 0;

Now type killall Dock into the Terminal window
To go back to the defaults, within the Terminal type the following:

defaults delete com.apple.dock autohide-time-modifier;

Now type killall Dock into the Terminal window

Author: Jas Dhaliwal

Hi, I’m Jas! I’m a digital marketer, technologist, and storyteller. I’m passionate about exploring the intersection of business, technology, and humanity. I hope you found this post informative. You can also follow me as @Jas on Twitter